Working with Scanned Images

The following features are available to users working with scanned images from the Scan Management screen:

Importing Scanned Document Images

You can import scanned document images in the Infinity Scan. The supported image format is TIFF and JPG.

To import scanned document images:

  1. Select Import Images from the File menu
  2. Browse to the location where the scanned document images are stored. Select and open the images. The imported images get displayed in the Thumbnail Pane.
  3. Note that you can import multiple images at a time.

Working with Scanned and Imported Images

Once you scan the document or import the scanned document image in the Infinity Scan, it gets displayed in the Thumbnail pane. The first scanned or imported document gets displayed at the top. When the pages are added to the thumbnail pane, they get added under the Document node. The document node is always a part of the batch. The batch node is provided to allow application of process definition to all the documents in the current batch. One document consists of number of pages. One batch consists of many documents. A batch is always a part of the process definition which has a scan trigger associated with it in Infinity Process Platform.

A document image is selected by clicking the image object in the Thumbnail pane. The selected image gets loaded into the image viewing pane.

When you scan or import the images in the Infinity Scan, all the images get added to Document 1, by default. Suppose, you have imported 8 images to Infinity Scan. All the images get displayed under the Document 1 node in Thumbnail Pane as shown in the following screenshot.


Figure: Infinity Scan - Thumbnail View

Now you want to add two pages to another document. Select the two pages you want to add to another document and click Add Document icon. The selected pages get added to Document 2 and the latest document that is Document 2 is displayed at the top in the Thumbnail pane. The currently selected document node is displayed in dark grey color. Note that these two documents are part of the same batch.


Figure: Thumbnail View - Two Documents

In the main toolbar, note the count of documents and pages displayed for the current scan batch. It should be two documents and eight pages.


Figure: Batch Information

Submitting Batch and Current Document

Once the documents are scanned, you may want to submit those document images to Infinity Process Platform Portal. The Submit option is available in the Main toolbar and in the File menu, as well.

The Submit option has two ways:


Figure: Submit

Jobs Queue

The jobs queue contains an upper jobs table that lists the jobs in the queue and relevant information about each job. The lower documents table lists the documents in the job selected in the Jobs Queue table. The Jobs Queue table contains jobs submitted only within the current day. Note the Status column in the Jobs Queue table. If batch or documents are submitted successfully to the Infinity Process Platform Portal then the status is displayed as Success. If not, it is displayed as Failed or Pending.

Click on Jobs Pending icon in the Main Toolbar of Infinity Scan.


Figure: Jobs Pending Icon

The Jobs Queue dialog is displayed.


Figure: Jobs Queue

You can perform the following operations on the jobs using the Jobs Queue toolbar.


Figure: Jobs Queue toolbar

Function Description
Export to Excel Exports table in Excel format
Export to CSV Exports table in csv format
Show/Hide Successful Jobs Displays or Hides jobs that have been successfully submitted to Infinity Process Platform. (default = Hide)
Show/Hide Pending Jobs Displays or Hides jobs that are pending. (default = Show)
Show/Hide Failed Jobs Displays or Hides jobs that have failed. (default = Show
Refresh Refreshes the Jobs Queue table.
Retry Job Retries the selected failed job.
Pause Job Pause the selected pending job.
Delete Job Deletes the selected failed or pending job.

You can perform following operations in the Document table of the Jobs Queue.

Function Description
Export to Excel Exports table in Excel format.
Export to CSV Exports table in csv format.

Generating Barcodes

Infinity Scan provides Barcode Generation facility that provides the ability to generate two types of barcodes. It automates the manual selection process in case of bulk scanning.

To generate barcode:

  1. Select Barcode Generator from the Tools menu. The Barcode Generator dialog is displayed.

  2. Figure: Barcode Generator

  3. Select the barcode symbology. The DataMatrix and QR are the available options.
  4. Select the checkbox Discard if you want to discard the barcode while submitting the document to Infinity Process Platform Portal.
  5. Select the process definition from the Process drop-down list.
  6. Select specific document or process attachment from the Document Type drop-down list. This drop-down list is populated based on the corresponding process definition. If it supports process attachment, then process attachment would be displayed in the drop-down list. You also need to select document type from the adjacent drop-down list. It lists all the document types in the system. By default, None option is selected.
    If the corresponding process definition supports document data type, then the specific document is displayed as appended in parenthesis for each document data. The adjacent drop-down list gets displayed in disabled state.

You can also print and save the barcode to the file.

Adding Process Data via Bar Codes

You can add process data when batch scanning in Infinity Process Platform Portal scan. It provides the following advantage:

To achieve adding process data via bar code, you need to specify out data paths for the process definition at modeling time. The process data panel in the barcode generator dialog box allows entering key/value pairs for out data paths and these values are written to the barcode when it is generated. Perform the following steps, to add process data via bar code:

  1. Deploy the model having a process that contains scan trigger and out data path for the process definition to be selected in the Barcode Generator dialog box
  2. Start the scan application
  3. Import the document in the scan application
  4. Select process from the Process drop-down list
  5. Select document from the Document drop-down list
  6. Select document type from the Document Type drop-down list


    Figure: Process Data Pane

  7. From the Tools menu, select Barcode Generator
  8. In the Barcode Generator dialog, select QR code from the Symbology drop-down list
  9. Select the process and document from the respective drop-down list in the Data panel


    Figure: Barcode Generator - Process

  10. Specify process data in the Process Data panel. Note that process data is written to the bar code if only process data is specified in this dialog box.

    You can use the Tab key to navigate within the process data table.

    It works the following way:


    Figure: Barcode Generator - Specify Process Data

  11. Save the barcode in the Barcode Generator dialog and close the Barcode Generator dialog

  12. Figure: Barcode Generator - Save Barcode

  13. From the File menu, select the Import Images option and import the saved barcode file
  14. Verify that the process data is populated along with bar code


    Figure: Verify - Process data and bar code

  15. Submit the Batch or the bar code document


    Figure: Submit Batch

Once you generate the barcode, the Infinity Scan identifies images with barcodes, extracts the encoded data and apply it to the scan batch. The generated bar code contains identity information like process definition and data. When you scan the images with this barcode, it identifies process definition and data for those images.

Once the bar coded document is submitted, you can also view and overwrite this process data in the Infinity Process Platform Portal.

Deleting Documents and Pages

You can delete the currently selected document and batch using the Delete icon provided in the Main toolbar of Infinity Scan.


Figure: Delete Icon

If you select Batch, all the documents and their pages get deleted. If you select Current Document, only the selected document pages get deleted.

Note that you can also delete pages using the Delete option provided in the Thumbnail toolbar.

Viewing Recycle Bin

All deleted documents are listed in the Recycle Bin. Click the Recycle Bin icon displayed in the Main toolbar.


Figure: Recycle Bin Icon

The Recycle Bin dialog is displayed.


Figure: Recycle Bin Icon

You can restore the pages, delete the pages or empty the recycle bin, if required.

Applying Metadata to the Batch

You can apply one process definition or metadata to whole batch.

To apply metadata:

  1. Click the Batch displayed in the Thumbnail Pane
  2. Select the process definition from the Process drop-down list displayed in the Image Viewer pane.
  3. Click the Apply to Batch button. The selected process definition contains the documents and pages of whole batch.

  4. Figure: Apply Metadata to the Batch

Specifying Document Type

You can specify following document types for the scanned images.

Image Enhancement Toolbar

Image Enhancement Toolbar and Scan Menu

Image Enhancement features in Infinity Scan allow users to configure image processing tools provided by the Kofax image processing engine. Modifications made to images by the image enhancement tools (deskew, despeckle) occur automatically, before they are displayed in the Scan Management screen.

Features supported by the Kofax Image Processing Engine include hardware-based Color Image Processing, Bar Code Recognition, Deskew, Patch Code Recognition, Black Border Removal, Despeckle, Line Removal, Image Enhancement Filters, and Time Stamp and Annotations.


Figure: Image Enhancement Toolbar

The following is a list of dialogs available from the Image Enhancement Toolbar and Scan Menu.

The Image Enhancement dialogs listed above are dependent on your installed scanner for functionality. Some functionality may be disabled if the scanner does not support the image processing function.

Barcode Properties

In Infinity Scan, Kofax recognizes QR and Data Matrix bar code types. The bar code engine works on color, bitonal, and grayscale images.

Click the icon on the Image Enhancement toolbar or click Bar code from the Scanner menu to access the Bar Code Properties dialog. If the Kofax bar code is disabled, Aspose is used for Bar code recognition.

A sample bar code dialog is shown below.


Figure: Bar Code Properties Dialog

Note: The dialog and functionality displayed above is dependent upon the installed scanner.

Instructions for configuring bar code properties can be found on the vendor supplied CD-ROM or can be downloaded from the Kofax Web site at www.kofax.com.

Black Border Properties

Click the icon on the Image Enhancement toolbar or click BlackBorder from the Scanner menu to access the Black Border Properties dialog.

A sample black border dialog is shown below.


Figure: Black Border Properties Dialog

Note: The dialog and functionality displayed above is dependent on the installed scanner.

This feature eliminates black edges generated by scanners with black backgrounds, thus reducing image file size while improving legibility.

Instructions for configuring black border removal can be found on the vendor supplied CD-ROM or can be downloaded from the Kofax Web site at www.kofax.com.

Deshade Properties

The Deshade module eliminates shaded backgrounds either present on the original document or generated at scan time.

Click the icon on the Image Enhancement toolbar or click Deshade from the Scanner menu to access the Deshade Properties dialog.

A sample Deshade Properties dialog is shown below:


Figure: Deshade Properties Dialog

Note:The dialog and functionality displayed above is dependent on the installed scanner.

Instructions on using and configuring the Deskew dialog can be found on the vendor supplied CD-ROM or can be downloaded from the Kofax Web site at www.kofax.com.

Deskew Properties

The Deskew dialog is used to correct image skew created during scanning. The deskew function employs an algorithm that compensates for image skew, resulting in images with zero degree skew. This feature does not require lines or leading edge borders to operate.

Click the icon on the Image Enhancement toolbar or click Deskew from the Scanner menu to access the Deskew Properties dialog.

A sample Deskew dialog is shown below.


Figure: Deskew Properties Dialog

Note: The dialog and functionality displayed above is dependent on the installed scanner.

Instructions on using and configuring the Deskew dialog can be found on the vendor supplied CD-ROM or can be downloaded from the Kofax Web site at www.kofax.com.

Despeckle Properties

The Despeckle module eliminates speckles either on the original document or generated at scan time.

Click the icon on the Image Enhancement toolbar or click Despeckle from the Scanner menu to access the Despeckle Properties dialog.

A sample Despeckle dialog is shown below.


Figure: Despeckle Properties Dialog

Note:The dialog and functionality displayed above is dependant on the installed scanner.

Instructions on using and configuring the Despeckle dialog can be found on the vendor supplied CD-ROM or can be downloaded from the Kofax Web site at www.kofax.com.

Image Filter Properties

The Image Filter module can be used to perform a variety of enhancements on lines and characters. Lines and characters can be smoothed, thickened, thinned, filled, or outlined in order to make them more legible and recognizable.

Click the icon on the Image Enhancement toolbar or click Image Filter from the Scanner menu to access the Image Filter Properties dialog.

A sample Image Filter dialog is shown below.


Figure: Image Filter Properties Dialog

Note: The dialog and functionality displayed above is dependant on the installed scanner.

Instructions on using and configuring the Image Filter dialog can be found on the vendor supplied CD-ROM or can be downloaded from the Kofax Web site at www.kofax.com.

Line Removal Properties

The Line Removal module can be used to eliminate all unwanted horizontal and vertical lines.

Click the icon on the Image Enhancement toolbar or click Line Removal from the Scanner menu to access the Line Removal Properties dialog.

A sample Line Removal Properties dialog is shown below.


Figure: Line Removal Properties Dialog

Note: The dialog and functionality displayed above is dependant on the installed scanner.

Instructions on using and configuring the Line Removal dialog can be found on the vendor supplied CD-ROM or can be downloaded from the Kofax Web site at www.kofax.com.

Patch Code Properties

The Patch Code module detects and recognizes up to six unique patch code types in color, bitonal, and grayscale. Patch codes can be used to recognize changes in batches, stop the scanner for manual setting adjustment, update scanner settings on the fly, or to signify any unique attributes in a set of documents.

Click the icon on the Image Enhancement toolbar or click Patch Code from the Scanner menu to access the Patch Code Properties dialog.

A sample Patch Code dialog is shown below.


Figure: Patch Code Properties Dialog

Note: The dialog and functionality displayed above is dependant on the installed scanner.

Instructions on using and configuring the Patch Code dialog can be found on the vendor supplied CD-ROM or can be downloaded from the Kofax Web site at www.kofax.com.

Streak Removal Properties

The Streak Removal module can be used to eliminate unwanted streaks, on the original document or generated at scan time.

Click the icon on the Image Enhancement toolbar or click Streak Removal from the Scanner menu to access the Streak Removal Properties dialog.

A sample Streak Removal dialog is shown below.


Figure: Streak Removal Properties Dialog

Note: The dialog and functionality displayed above is dependant on the installed scanner.

Instructions on using and configuring the Streak Removal dialog can be found on the vendor supplied CD-ROM or can be downloaded from the Kofax Web site at www.kofax.com.

Reset Scanner

You can reset the scanner using this option. To reset the scanner:

Click the icon on the Image Enhancement toolbar or click Reset Scanner from the Scanner menu to reset the scanner.