Getting Started

If not already done, download the Infinity Process Platform features as described in the Installation Guide.

Apart from the Infinity Process Platform installation, you only need a Tomcat installation to go through this tutorial. Refer to the Infinity Release Notes for details on the Tomcat version supported with the current release.

Naming

As a start some names of the product are described here. For an overview on the provided packages provided by Infinity Process Platform, refer to the Installation Guide.

Infinity Process Platform

This is the general product name.

Infinity Process Engine

This name is used for the runtime component of Infinity Process Platform.

Open the Process Workbench

To open the Infinity Process Workbench, start your Eclipse environment, where you installed the Infinity Process Workbench Eclipse plugins and features.

We will now add the following views to the desktop:

  1. Open Window > Show Views > Other....
  2. Add the Server > Servers View and the Process Manager > Process Model Bookmarks.

So, now we are ready to start the tutorial.

Starting the Modeling

Before your business process can be executed, you must model its elements (activities to be performed, variable definitions, applications and resources) as well as the relationships between these elements. For this purpose Infinity Process Platform provides the Infinity Process Workbench where you can define your processes by drawing diagrams. Diagrams in Infinity Process Platform contain process definitions, on the basis of which other components of Infinity Process Platform, e.g. the Infinity Process Platform Portal, can control the enactment of your processes. The Process Workbench and the Infinity Process Platform Portal will be introduced in the following sections.

In our ACME example we will use applications and data implemented in Java, which have to be integrated in the business model. We have prepared the applications and data classes so that you can proceed with this tutorial without having to implement the model-specific components yourself. To get the example resources, download the following ZIP file:

all-tutorials.zip

You find the resources in folder support-case.

In the following figure you see a screenshot of the complete ACME Workflow example model:

The ACME Workflow Model
Figure: The ACME Workflow Model

Setting up Embedded Tomcat in Eclipse

Eclipse provides integration for the Apache Tomcat Web environment and this can be used for rapid Infinity Process Platform deployments within Eclipse.

To establish Tomcat integration in Eclipse (this only needs to be done once for all successive deployments. It is not required for each Infinity Process Platform deployment):

  1. From the Eclipse main menu choose File > New > Other...

    ! Tip: If your Eclipse installation does not have Server in the list of available objects to create, you will need to update your environment with the necessary plug ins of the Eclipse Web Tools Project, or use the Eclipse installation which comes with the normal Infinity Process Platform distribution.

    Eclipse Server dialog

  2. Select Server > Server.
  3. Click Next.

    Tomcat

  4. Select Tomcat vx.x Server
  5. Click Finish if you previously configured a Tomcat Server with your Eclipse Workbench.
  6. Otherwise select Next.
  7. Browse to the folder of your Tomcat installation.

    Browse to Installation Folder

  8. Select Finish.

If your Eclipse desktop does not yet have a view for Servers as shown below, select Window > Show View in the main menu (or select the Show View button in the left lower corner of your Eclipse window) and choose Other... > Server > Servers to open it.

Eclipse server view

Creating an Eclipse Project with Process Manager Facets

For this tutorial we will use a Dynamic Web Project (from the Eclipse Web Tools Project). To create a new Dynamic Web Project, follow these steps in Eclipse:

  1. On the main menu select File > New > Project....
  2. In the upcoming wizard choose Web > Dynamic Web Project.
  3. Click Next

    Creating a Dynamic Web Project - Step 1
    Figure: Creating a Dynamic Web Project - Step 1

  4. Name your project Support-Case
    Tip: Give the project a name that does not contain spaces to make Web references easier. The project name will become part of a case sensitive URL in a later part of this tutorial.
  5. Make sure that the target runtime is set to the supported Apache Tomcat version. If not, please set up the Apache Tomcat server as described in the preceding section Setting up Embedded Tomcat in Eclipse.
  6. Select Dynamic web module_version 2.5, as 3.0 is currently not supported by IPP.

    dynamic web module version
    Figure: Set the dynamic web module version

  7. In the Configurations entry, select Infinity Process Platform Portal for Dynamic web module 2.5 in the drop down list. The facets provided with this configuration contain among others the Infinity Process Platform Portal facet, which enables you to run the Infinity Process Platform Portal as Web application of your dynamic Web project. The provided facets can be added or removed later as desired. Please refer to the section described in section Process Manager Facets of the Rapid Application Development guide for detailed information on the Process Manager facets.

    Select the IPP Portal
    Figure: Select the IPP Portal

  8. Click Next.
  9. Leave the default values for source and build path and select Next.

    Set Build Path
    Figure: Set Build Path.

  10. Leave the entries in the Web Module dialog and click Next.

    Web Module Dialog

  11. In the JSF Capabilities dialog enter the following values:

    JSF Capabilities Dialog

  12. Click Finish.
  13. A dialog asking if you like to switch to the J2EE perspective opens. The J2EE perspective is optional. It will not be needed so for this tutorial, so click No.

    Changing the Perspective
    Figure: Change the perspective

A dialog opens to inform you to set a location for the repository path:

Repository Path Warning
Figure: Repository Path Warning

Please set a repository path as described in the section Setting the Repository Path of the Document Service Integration Guide.

After Eclipse created the project, you see a new project folder in the Package Explorer view:

New Dynamic Web Project in Package Explorer
Figure: New Dynamic Web Project in the Package Explorer

! Tip: You can use different explorer in eclipse. If you like to see all files under your project open the Navigator view.

Creating a new Model

The next step is either to open an existing model or to create a new one. Both can be done in the Infinity Process Platform Process Workbench. Since no model exists in our introductory scenario, we will proceed with creating a new model.

Models

Three aspects are essential for a proper understanding of the notion and the function of a model:

To create a new model:

  1. Right-click your project in the Package Explorer and select New > Other...
  2. In the dialog popping up, choose Process Manager Wizards > Process Model.
  3. Click Next.

    Creating a New Model
    Figure: Creating a New Model

  4. In the upcoming dialog fill in the model name ACME Workflow Model


Figure: Fill in Model Name

Finish

An open (editable) version of the ACME Workflow Model has now been created.

Importing the Model

If you wish to omit the modeling phase and just set up this scenario in a minimum of time, you can import an existing model instead of creating one manually. In the main menu use the option File > Import... > Process Manager > Process Model. In the appearing dialog, choose Infinity Process Platform XML as Model Type and select the file ACMEWorkflowModel.xpdl residing in your Infinity Process Platform installation in the directory examples/support-case/dat.

On Handling Diagrams

Now you are ready to start building diagrams. In the Process Workbench window you will find the Outline view area, organizing the processes in your model and the components used in or by these processes. The Package Explorer area will display your projects and the created model files.

Initial ACME Model Screen
Figure: Initial State of a Model in the Infinity Process Workbench

Diagrams

Diagrams are principally bound to a single process definition and contain a series of activities with the information connected to these activities (activity performers, data and applications). With each newly created process definition, a default diagram for this definition is created. You can add an arbitrary number of diagrams to a process definition. To get more detailed information on diagrams please refer to the chapter Working with Diagrams of the Infinity Process Platform Modeling guide.

The diagrams which you can see in the Outline view tree under the model element (which is the Infinity Process Platform icon root element) are intended to visualize the hierarchies of participants in your model and the dependencies among process definitions, e.g. a graph of a process with its sub-processes. In this tutorial we want to direct your attention to diagrams bound to a single process definition, so we will focus on the diagrams which appear in the tree view after a process definition has been created.