Running Simulations

Before you can run simulations you need to create

Opening the Simulation Perspective

Open the simulation perspective, which provides you with the necessary views like the Simulation Statistics View. Select Window > Open Perspective > Other... and choose Process Simulation Perspective in the upcoming dialog.

Open the Simulation Perspective

Now the simulation perspective opens with the following standard views needed for simulation:

The Simulation Perspective

You can adjust and extend the simulation perspective to your own requirements.

The Simulation View

To run simulations and obtain simulation results, you must display the Simulation Statistics View. In case it is not already open, display it via Window > Show View > Other ... and the following selection in the Show View pop-up dialog:

Simulation View

Starting and Stopping Simulations

You can

buttons with the corresponding buttons

in the simulation view.

The different tabbed panes in the simulation view will display the current values of runtime parameters (e.g. participant queue lengths). The time slider and the corresponding timestamps labels

will indicated the current position on the time axis during the simulation run.

After a simulation run is completed you can use the slider to review values of runtime parameters at any time in the simulation run interval.

Obtaining Tabular Results

The simulation view different tables are displaying runtime parameters. These tables and parameters are described in the following subsections.

Process Durations

Activity Durations

Transition Statistics

Participant Queue Lengths

Application Queue Lengths

Path Statistics

Drag and Drop To Microsoft Excel

You can drag and drop the content of any table in the simulation view into Microsoft Excel to further evaluate simulation results as indicated in the following screenshot after dragging and dropping from the activity statistics tab:

Obtaining Graphical Results

Obtaining Charts

To activate charts in the process model diagrams, push the chart button

in the simulation view. Charts will be displayed as follows.

You can enlarge the charts with moving the mouse cursor over the charts.

If you want to pin an enlarged chart, press the

button on the upper right corner of the enlarged chart.

Critical Paths

To visualize critical paths select a path from the Path pane in the simulation view

Path Selection

The corresponding path in the process model diagrams will be highlighted in red as follows

To deselect the highlighted path, select the top level entry in the Path pane:

Path Top Level

Out of Memory Errors

If you have installed Eclipse Mars via the old-style installation process and an out of memory error occurs while running a simulation in the modeler please increase the heap size available to Eclipse. To do this edit the eclipse.ini file, residing in your Eclipse folder.

Now set the minimal and maximal heap size, for example:

-vmargs
-Xms128m
-Xmx512m
-XX:MaxPermSize=128m

Hereby the -Xms option specifies the stack space and -Xmx the maximum heap size. MaxPermSize specifies the maximum PermGen size. PermGen means "Permanent Generation" and it is a part of memory where all permanent objects are stored.

Note that these settings are already provided per default in case you have installed Eclipse via the new Eclipse installer. Please refer to https://www.eclipse.org/downloads/installer.php for details.